Firefox 1.5와 Extension과의 호환성 문제

Firefox 1.5가 릴리즈되었습니다.

Firefox 1.5

릴리즈 노트에도 크게 놀랄 만한 사실은 없고, 사실 크게 달라진 점은 느끼기 힘든 것 같습니다. 다만 한가지, 저는 탭을 보통 수십개씩 쓰는데, 기존에는 윈도우 너비를 넘어서는 탭은 탭을 닫는 버튼 뒤에 가려졌었는데, 이제는 탭을 닫는 버튼이 탭에 가려지는 것이 좀 이상한 것 같습니다. 그 외에는, Canvas element를 사용한 3D FPS 게임(?) Canvascape 정도를 즐길 수 있게 되었다는 정도?

Extension과의 호환성

모든 Extension이 자연스럽게 1.5에 호환되는 것은 아닌 것 같습니다. Google ToolbarAdblock, Onfolio, IE View, IE Tab, del.icio.us Extension 같은 것은 별 문제가 없었으나, 제가 중요하게 사용하는 SessionSaver Extension은 호환이 되지 않는다고 하더군요. (GreaseMonkeyStarDownloader 같은 것들은 그다지 중요하게 사용하고 있진 않습니다) 따라서, 자신이 사용하고 있는 중요한 Extension이 아직 Firefox 1.5에 호환되지 않는다거나 그다지 확신이 서지 않는다면 1-2주 정도 Firefox 1.5 설치를 미루는 것이 좋은 선택이라고 생각되는군요.

한가지 해결책은 직접 Extension의 Firefox 버전 요구사항을 수정하는 겁니다. 자신의 Documents and Settings 폴더에서 Mozilla/Firefox/Profiles/YOUR_PROFILE/extensions 폴더를 뒤져서, 특정 Extension의 install.rdf 파일을 적절하게 수정해주면 됩니다. 물론 Extension에 따라 동작하리라는 것은 보장할 수 없습니다. (이와 관련해서 Extension 관련 변경사항을 알아보면 좋겠군요. 만약 있다면.)

<em:targetApplication> <!-- Firefox -->
<Description>
<em:id>{ec8030f7-c20a-464f-9b0e-13a3a9e97384}</em:id>
<em:minVersion>0.7</em:minVersion>
<em:maxVersion>1.5</em:maxVersion>
</Description>
</em:targetApplication>

대충 위와 같은 항목에서 em:maxVersion element를 수정해주면 되는거죠. 호환되지 않는 extension의 install.rdf를 잘 찾아낼 수 있다면, 고치는 것은 그리 어렵지 않습니다. extensions 폴더 아래에는 extension의 특정한 GUID를 이름으로 가지는 폴더들이 있는데, 그 아래의 chrome 폴더를 보면 실제 extension 이름을 알아볼 수 있는 경우가 대부분입니다.

Update 2005/12/1: 프리버즈님 말씀대로 del.icio.us extension의 최근 버전에서는 Firefox 1.5를 지원합니다. 이에 관한 내용을 수정하였습니다.

7 thoughts to “Firefox 1.5와 Extension과의 호환성 문제”

  1. lunamoth/Firefox 버전을 수정해버리는 방법이로군요. ;(
    프리버즈/말씀하신대로, delicious 최근 버전에서는 1.5를 지원하는 것이 사실이군요. 자동 업데이트에 의존하고 있었는데, 뭔가 문제가 있었던 모양입니다.

  2. FireFox 1.5 Release

    FireFox 1.5rc3까지 내놓고 11월 29일 1.5를 Release하였다. 모질라진을 살펴보면 소프트웨어 업데이트 시스템, 네비게이션의 속도, 개인 프로필 정보 삭제하는 옵션, 마우스 드래그로 탭의 재배치, …

댓글 남기기

이메일은 공개되지 않습니다. 필수 입력창은 * 로 표시되어 있습니다

이 사이트는 스팸을 줄이는 아키스밋을 사용합니다. 댓글이 어떻게 처리되는지 알아보십시오.